Installing Adobe Flash Player

Follow

The Gizmos library of over 400 simulations is now available in HTML5. This makes Gizmos accessible via a web browser on popular platforms like Chromebooks, iPads, and Android devices.

However, a very small number of Gizmos still require the latest version of Adobe Flash Player. These Gizmos will be converted to HTML5 in the near future.

  1. Go to https://get.adobe.com/flashplayer, and select Install.
  2. If prompted to download software other than Adobe Flash Player, remove the check from the Optional Offer check box.
  3. Select the Install Now
  4. Follow the prompts to complete the three-step process.

You can use our Systems Test Page to find out if your device meets all of our system requirements:

www.explorelearning.com/index.cfm?method=cCorp.dspTest

 

Related articles:

System Requirements and Systems Test Page

Gizmos and HTML5

Powered by Zendesk